ManualRequirementsCN

From Request Tracker Wiki
Jump to navigation Jump to search

Prev: ManualIntroductionCN --- Up: UserManualCN --- Next: ManualInstallationCN


REQUIREMENTS

需求

RT is a fairly large, complex piece of software. It makes some (ok, lots of) assumptions about the environment in which it runs, which you will have to fulfill during installation.

RT 是一个相当大的,复杂的软件作品。它制定了一些(好吧,很多)您在安装期间必须满足的有关运行的环境的假设。

If you're working with an already installed RT you don't need to know any of this now.

如果您正在用一个安装好的 RT 来工作,您现在不需要知道这些。

To properly install RT you'll need some things:

正确地安装 RT ,您会需要的一些东西:

Knowledge

知识点

  • root access to the server you're going to install it on
  • how to add aliases to your mail system
  • how to start and stop your web server
  • how your distribution mangles the webserver configuration files.
  • 登录到您将要安装的服务器的root用户。
  • 怎样添加别名到您的邮件系统
  • 您的发行版怎样更改web服务器配置文件。

Make choice

做选择

In installing an application as large and pervasive as RT, which depends on many other things, you will often have to make the decision "do I provide it a separate version of the thing it requires, or do I upgrade my system's facility to the proper, new-enough version?" This is a difficult question to answer in some cases, as it depends on the level of systems administration experience you have. We can't answer it for you but we'll attempt to make clear what effect the possible choice may have on how you install and run the package. See the Installation Guides - your distro may have a packaged version of RT.

安装一个像 RT 一样巨大的和无处不在的应用,要依赖很多其他的事情,您会常常不得不做选择“我应该给它提供一个它需要的独立版本呢,还是应该升级我的系统功能到合适的、够新的版本?”在某种情况下,这是一个很难回答的问题,因为它随您具备的系统管理经验的水平而定。我们不能给您作答,但是我们将尝试让——对如何安装和运行软件包,导致可能的选择可能有什么——变清晰。查看安装手册——您的发行版可能有一个 RT 的套件版本。

RT source code

RT 源代码

The latest version is available at http://www.bestpractical.com/rt/download.html

最新的可用版本在这个地方:http://www.bestpractical.com/rt/download.html

Perl

WARNING: For RT 3.0.0 and greater you need Perl 5.8.3 or newer. It contains significantly enhanced support for Unicode and non-English languages. Perl 5.8.3 fixed major bugs - using prior versions may cause data corruption. If your distribution uses an older Perl version, you can compile your own - see CompilingPerl. Or you can upgrade your system's version of perl.

  • 警告 对于RT 3.0.0和更高版本,你需要 Perl 5.8.3或者更新。它包括了对 Unicode 和非英语语言的显著地增强的支持。perl 5.8.3修补的主要漏洞——使用较早的版本可能导致数据中断。如果您的发行版使用一个旧的Perl,你可以自己编译——参见 CompilingPerl。或者你可以升级你的系统的Perl 的版本。

Note that if you're using a packaged perl and a packaged Apache, you probably need to use your distribution's packaged Apache::DBI and mod_perl as well, and all of these need to be version compatible with RT -- it's vaguely possible this might mean you need to uninstall all of the managed packages and build these things from scratch... at which point you might want to reconsider which distribution you want to use.

注意,如果您正使用一个 perl 套件和一个 Apache 套件,您大概需要使用您的发行版的 Apache::DBI 套件还有 mod_perl ,并且所有的这些需要和 RT 版本兼容——这大概可能意味着您需要卸载 所有的 管理套件和从零搭建这些事情…… 基于这一点,您可能打算重新考虑您要用哪个发行版。

If you will be running RT 3.0.x or earlier under FastCGI, you need support for setgid perl scripts. RT 3.2 and later do not need this. See details below and on the FastCGIConfiguration page. (There really isn't much reason to newly install a version that old, so that's all we'll say about this now.)

如果您要在 FastCGI 下运行 RT 3.0.x 或者更早 ,您需要 setgid 的 perl 脚本的支持。RT 3.2和以后的版本则不需要。在下面和 FastCGIConfiguration 页面可以了解更多。(实际上没有多少理由全新安装一个旧版本,因此我们也就是在这里说说。)

Perl modules

Perl 模块

If all of that sounds vague, don't worry: a tool included with RT takes care of the installation of most of these automatically (see ManualInstallation). The tool supplied with RT uses Perl's CPAN system (http://www.cpan.org) to install modules. Some operating systems package some or all of the modules required and you may be better off installing the modules that way.

如果还没有说清楚,别担心:RT 里有一个自动化处理大多数的这些的安装的工具(参见 ManualInstallationCN )。这个工具为 RT 提供使用 Perl 的 CPAN ( http://www.cpan.org )系统来安装模块。某些操作系统整合了一些或者全部需要的模块,而且您可能用那种方式来安装模块会更好。

And, finally, you might find that you'll need to mix these two approaches; on SuSE 10.3 for example, fixdeps will install everything except Apache::DBI.

总之,您可能发现您会需要混合使用这两种方式;例如,在 SuSE 10.3 上,除了 Apache::DBI fixdeps 会安装所有的东西。

Currently (April,2008 - RT 3.6.6) the dependency "HTML::FormatText" will not install due to a failure in a subdependency: "Font::AFM". The latter fails with a test result: t/afm.....skipped (no reason given). You will need to install this manually with CPAN using the command "force install Font::AFM". Afterwards, the "HTML::FormatText" module can be installed ok.

目前(2008年4月- RT 3.6.6)依赖 “HTML::FormatText” 会由于一个子依赖 “Font::AFM” 中的失败而不安装。后来的失败有一个测试结果:t/afm.....skipped (没有给出原因)。您将需要用 CPAN 用命令 “force install Font::AFM” 来手动安装。然后,“HTML::FormatText” 模块可以被安装好了。

NCFTP

NCFTP

Some platforms, e.g. CentOS 4.x, will also require the freely available NcFTP Client (http://www.ncftp.com/ncftp/) in order to satisfy some configuration dependencies for the Perl CPAN system.

有些平台,比如,CentOS 4.x,也需要可自由得到的 NcFTP Client (http://www.ncftp.com/ncftp/),以便为 Perl CPAN 系统满足一些配置的依赖关系。

You can configure to avoid this requirement during the setup configuration of CPAN by telling the configuration dialog that there is no "ncftp" executable and then selecting only "http" CPAN Mirrors. This may also be advantageous if your system is behind a corporate firewall which does not allow FTP.

您可以配置避开这个需求,在设置 CPAN 的配置的时候,通过告诉配置对话框,没有 “ncftp”执行,然后只选择 “http” CPAN 镜像。这可能也是有利的,当您的系统在一个不允许 FTP 的企业防火墙后面的时候。

Database backend

数据库后台

RT stores its data in a database. You can choose from the following database management systems (DBMS):

RT 用一个数据库存储它的数据。您可以从下面的数据库管理系统(DBMS)中选择:

  • We recommend MySQL 4.0.18 or newer with support for InnoDB.
  • PostgreSQL 7.4 or later will also work
  • Oracle 9iR2 or newer
  • 我们推荐 MySQL 4.0.18 或者新的 支持InnoDB的 的版本。
  • PostgreSQL 7.4 或者以后的都可以。
  • Oracle 9iR2 或者更新的。

If your system already has a DBMS engine installed and working, you're probably best to use that one.

如果您的系统已经安装有一个DBMS引擎并正在工作,您最好就用它。

Web server

Web 服务器

We recommend using Apache version 2.x with [mod_perl] 2 or a webserver with FastCGI support.

我们推荐使用带有 [mod_perl] 2的 Apache 2.x 版本或者带有 FastCGI 支持的 web 服务器。

mod_perl vs FastCGI

mod_perl vs FastCGI

You don't need both mod_perl and FastCGI, you have to install and configure only one thing. You should choose the software you're familiar with, but if you not familiar with either, don't panic, here are short descriptions of both projects and how well each works with RT.

mod_perl 和 FastCGI ,您 不用两个都要 ,您必须只安装和配置其中的一个。应该选择您熟悉的,但是,如果您都没用过,也别怕,这儿有它们的简单介绍和如何与RT一起工作的更好。

mod_perl

mod_perl

[mod_perl] project has two major stable releases: mod_perl 1.x and mod_perl 2.x; in the middle there is development versions mod_perl 1.9x. Let see which releases you can use:

[mod_perl] 项目有两个主要的稳定版本:mod_perl 1.x 和 mod_perl 2.x;在中间是开发版本mod_perl 1.9x。让我们看看您可以用哪个版本:

  • mod_perl 1.x is supported release, but this mean you must use Apache 1.3.x, because mod_perl 1.x works only with Apache 1.3.x. mod_perl 1.x must be built with EVERYTHING=1 option(most distribution packages have this option on). For an excerpt, see ManualApache. Using mod_perl with Apache 1.3.x could lead to massive stability problems.
  • mod_perl 1.x 是支持的版本,但是这意味着你 必须使用 Apache 1.3.x ,因为mod_perl 1.x 只与Apache 1.3.x 一起工作。 mod_perl 1.x 必须与EVERYTHING=1 选项(大多数发行版套件都开启这个选项)一起被创建。对于摘要,参见 ManualApache 。与 Apache 1.3.x 一起使用 mod_perl 可能导致大量稳定性问题。
  • We don't recommend to use development 1.9x versions, because of development status. Also mod_perl 2.x was released and it's stable branch of the 1.9x development versions, so you wouldn't get much support from mod_perl users and developers if you use mod_perl 1.9x. RT-3.4.4 and greater won't work with development 1.9x releases.
  • 我们 不推荐 使用开发版 1.9x,因为开发状态。 而且mod_perl 2.x 已经发布,并且它是1.9x 开发版的稳定分支,因此如果您使用mod_perl 1.9x,你将不能从mod_perl 用户和开发人员那儿得到更多的支持。RT-3.4.4 和更高版本 不和 1.9x 开发版一起工作。
  • mod_perl 2.0 has been released with major API-changes in mod_perl 2.0-RC3 which lead to incompatibities that also affect RT, see this mailing-list message.
  • mod_perl 2.0随着主要的 API-调整一起被发布在 mod_perl 2.0-RC3 中,这导致不兼容也会影响RT,参见这里 mailing-list message
    • So RT-3.4.3 or any prior versions is totally unsupported on mod_perl 2.x.
    • mod_perl 2.x has been marked as supported in RT 3.4.4. There is no mentioning of incomplete support in any way. See this mailing list message.
    • If you experience issues getting mod_perl 2.x+apache 2.x up and running, consider using apache 1.3.x + mod_perl 1.x or FastCGI instead, though this is much less likely than it used to be.
    • 因此 RT-3.4.3 或者任何以前的版本在 mod_perl 2.x 上 *统统不被支持 *。
    • 在RT 3.4.4中, mod_perl 2.x 被 标记为支持 。并没有提及任何方式的不完全的支持。参见 mailing list message
    • 假如您遭遇让 mod_perl 2.x+apache 启动和运行的问题,考虑用apache 1.3.x + mod_perl 1.x 或 FastCGI 替代,尽管这比之前没什么不同。

For CentOS-4.6 and RT 3.6.6, you can get a supported Web Stack by enabling the "centosplus" repository in Yum and doing a "yum update". If you try to use mod_perl2 on CentOS4 without "centosplus" you will lose hair.

对于 CentOS-4.6 和 RT 3.6.6,您可以通过用 Yum 启用 “centosplus”库并做一个 “yum update” 来获得一个被支持的 Web Stack。如果您尝试在没有 “centosplus”的 CentOS4 上使用 mod_perl2 ,您会烦透的。

FastCGI

FastCGI

You can use FastCGI with Apache 1.3.x and 2.x. You can use FastCGI with other HTTP servers, but this functionality is not tested very well (if at all).

你可以与 Apache 1.3.x 和 2.x 一起使用FastCGI 。你可以与其他 HTTP 服务器一起使用FastCGI ,但是这个功能没有被测试的很好(如果有的话)。

In RT versions prior to 3.2, RT's FastCGI handler runs setgid to the "rt" group to protect RT's database password. You may need to install a special "suidperl" package or reconfigure your perl setup to support "setuid scripts" if you intend to use RT with FastCGI.

在RT 3.2以前的版本里, RT 的 FastCGI 处理机运行 setgid 给“rt”组以保护RT 的数据库密码。如果你打算与 FastCGI 一起使用 RT ,你可能需要安装一个特别的“suidperl”包或者重新配置你的perl 设置来支持“setuid scripts”。

  • Debian GNU/* 3.0+: the package which installs suidperl is called perl-suid, and should work without any tweaking.
  • FreeBSD 4.2+: the package is called sperl, and should install a suidperl that just works
  • Conectiva Linux 6.0+: suidperl is installed by default when perl is installed, but the program /bin/suidperl is not setuid. You must use chmod to make it setuid.
  • Debian GNU/* 3.0+:这个发行版已经安装了叫做 perl-suid 的 suidperl ,而且应该不需要任何调试就可以工作。
  • FreeBSD 4.2+:该套件叫做 sperl ,并且应该安装一个 suidperl 才可以工作。
  • Conectiva Linux 6.0+ : 在安装perl 的时候,suidperl 就已经默认安装,但是程序 /bin/suidperl 不是setuid 。您必须使用chmod 使得它 setuid。

Prev: ManualIntroductionCN --- Up: UserManualCN --- Next: ManualInstallationCN


到中文版的首页 >> CNEdition